Massive lag with mining Gems

gem2Does anyone else experience this? Massive lag when mining Gems? It happens on the map and with searches, and it is frustrating. Firstly, when I search for mines in the Watch Tower, the results are almost always outdated! Unoccupied mines that show up enemy or neutral, or exhausted mines listed as normal. Strangely, friendly mines are almost never wrong…..

Then when I click to go to the mine, it can take up to a minute for the mine to actually show up! At first it shows the normal Wild it used to be, and then after some time it refreshes the map or something and shows up properly..

And when it comes to mining itself, the game starts to lag enormously when mining a couple of mines. I usually mine when America is asleep, and use a few sets of pickaxes in one go, but doing so results in the map almost freezing completely. Getting back to city view completely removes this so it is definitely the mining causing?

Am I the only one (or my server, as I’ve heard the complaint from more people) and what could possibly cause these problems? Frustrating to say the least….

Advertisements

7 thoughts on “Massive lag with mining Gems

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s